Computer Related > Microsoft Store & Photos Legal Questions
Thread Author: No FM2R Replies: 9

 Microsoft Store & Photos - No FM2R
..have both stopped working on my PC.

Everything was fine until a few days ago.

Try to open the Store and it opens for literally 2 seconds and closes again. No error messages.

Try to open Photos and it does the same.

Try to open Photos by double clicking on a JPG (or any other image file) and it says file not found. JPGs and other image files open just fine with anything other than "Photos"

Photos, Video Editor and Microsoft store all have a thick white line under them in the Start Menu

As far as I can tell everything except those two are working just fine. (Vid. Ed & Photos are actually the same program I think)

I have tried [most more than once];
- Troubleshooter
- Store Reset from app menu
- Store & Photos uninstall and install
- DISM
- SFC
- WSReset [fails with "cannot find 'ms-windows-store:PurgeCaches']
- Have changed and changed back Apps folder ownership and access settings
- Created new accounts (with MS address and without)
- Have run the normally brilliant "Tweaking.com - Windows Repair"
- Have even done a full repair install
- checked and rolled back, and then later reinstalled Windows Updates.

I have scoured Google and tried every suggestion I could find.

I have nothing left except wipe the disk and do a full clean install, which I really, really don't want to do.

It's a long shot, but anybody got any other thoughts?
 Microsoft Store & Photos - No FM2R
I think it broke 3 or 4 days ago.

I notice that in "Apps & Features" the Microsoft Store is shown as 16kb.
 Microsoft Store & Photos - Zero
I had an update a few days ago that updated MS photos to a new product i think
 Microsoft Store & Photos - No FM2R
Did you? I didn't notice that. I'll check. Thank you.
 Microsoft Store & Photos - Zero
Just checked it was the photos engine add on that got installed.
 Microsoft Store & Photos - Crankcase
WSReset [fails with "cannot find 'ms-windows-store:PurgeCaches']

Almost matches the possible error shown here, where it also describes what to do in an elevated PowerShell to fix that problem:

www.thewindowsclub.com/windows-store-not-opening

Just in case that's useful.
Last edited by: Crankcase on Tue 25 Feb 20 at 17:41
 Microsoft Store & Photos - No FM2R
I appreciate you looking CC, but I've tried that approach. it results in;

Add-AppxPackage : Cannot find path 'C:WINDOWSWinStoreAppxManifest.xml' because it does not exist.
At line:1 char:1
+ Add-AppxPackage -DisableDevelopmentMode -Register C:WINDOWSWinStore ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : ObjectNotFound: (C:WINDOWSWinStoreAppxManifest.xml:String) [Add-AppxPackage], ItemNot
FoundException
+ FullyQualifiedErrorId : PathNotFound,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPac
kageCommand



It's clearly relevant to the problem, but I cannot make a link. The directory does not exist, it probably should exit, but I cannot cause it to exist. Manually creating it does not work.
 Microsoft Store & Photos - No FM2R
I think it's related to access to the windowsapps directory.

I can get to it via the Shell, but not through Windows Explorer.
 Microsoft Store & Photos - tyrednemotional
...maybe not relevant, but update KB4532693 has been causing a lot of problems in the last (just over a) week.

I can't find any direct reference to your problems, but it has seemingly been responsible for "randomly" deleting files, profiles, etc.

It hit my machine 10 days ago, and I've escaped any (noticeable) effects, but you might just want to research it a little.
 Microsoft Store & Photos - No FM2R
>> I think it's related to access to the windowsapps directory.

And something to do with install$location.

I think it's probably beaten me.
Latest Forum Posts